Fixed: Installation Win10 64bit

Bei Problemen bei der RailControl Installation
Post Reply
mobarainer
Posts: 39
Joined: Mon Nov 23, 2020 6:01 pm

Fixed: Installation Win10 64bit

Post by mobarainer »

Hi,
habe das Programm noch auf meinem WIn10 PC installiert, wesentlich größerer Screen, höhere Auflösung.
Den Download habe ich in C:\Modellbahn\railcontrol installiert.
Die EXE startet, aber was dann? Wenn ich im Browser http://localhost:8080 eingebe kommt nichts!?
Was muß man machen um das Programm im Browser laufen zu lassen?
Bitte um Hilfe.
Gruß
Rainer
User avatar
teddy
Site Admin
Posts: 264
Joined: Thu May 07, 2020 2:39 pm
Contact:

Re: Installation Win10 64bit

Post by teddy »

Hallo Rainer

Wenn du RailControl startest geht ja ein Fenster auf. Was ist darin zu sehen? Kannst du davon ein Bild einstellen?

Gruss
Teddy
mobarainer
Posts: 39
Joined: Mon Nov 23, 2020 6:01 pm

Re: Installation Win10 64bit

Post by mobarainer »

Hi, da ist es.
Rainer
Win10Start.png
User avatar
teddy
Site Admin
Posts: 264
Joined: Thu May 07, 2020 2:39 pm
Contact:

Re: Installation Win10 64bit

Post by teddy »

Hallo Rainer

Das sieht schon mal gut aus.

Was hast du für eine Fehlermeldung im Browser?

Kannst du versuchen in railcontrol.conf den WebserverPort auf 8082 zu ändern und im Browser dann http://localhost:8082/ aufrufen?

Gruss
Teddy
mobarainer
Posts: 39
Joined: Mon Nov 23, 2020 6:01 pm

Re: Installation Win10 64bit

Post by mobarainer »

Bing, Teddy,
voller erfolg.
Rainer
User avatar
teddy
Site Admin
Posts: 264
Joined: Thu May 07, 2020 2:39 pm
Contact:

Re: Installation Win10 64bit

Post by teddy »

Hallo Rainer

Das freut mich. Ich vermute, dass auf diesem Port schon ein anderes Programm aktiv war. Ich lerne daraus, dass ich bei besetztem Port eine entsprechende Fehlermeldung ausgeben sollte.

Gruss
Teddy
mobarainer
Posts: 39
Joined: Mon Nov 23, 2020 6:01 pm

Re: Installation Win10 64bit

Post by mobarainer »

Hi,
ja, lässt sich über den Port 8082 zwar verbinden, läuft aber nicht fehlerfrei. Die Zentrale bzw. der HSI-S88 lässt sich nicht konfigurieren. Nach Eingabe des Pseudonamens und der Auswahl der Zentrale erscheint links Loading...
und das war es dann. Nach mehreren Klicks auf IO-Button hängt es dann. Der Browser lässt sich beenden, der Server nur über den Programm-Manager.
Rainer
User avatar
teddy
Site Admin
Posts: 264
Joined: Thu May 07, 2020 2:39 pm
Contact:

Re: Installation Win10 64bit

Post by teddy »

Hallo Rainer

Den RailControl-Server kannst du im RailControl-Server-Fenster mit Q + Enter beenden. Das sollte wohl noch in die Dokumentation fliessen.
Zumindest unter Linux funktioniert auch Ctrl + C (das ist unter Linux ein Quasi-Standard).

Bezüglich dem Problem im Browser: Könntest du mir bitte einen Screenshot des Browsers mit Fehler sowie ein Screenshot des Servers einstellen?

Gruss
Teddy
mobarainer
Posts: 39
Joined: Mon Nov 23, 2020 6:01 pm

Re: Installation Win10 64bit

Post by mobarainer »

Hi Teddy, mache ich mal morgen.
Rainer
mobarainer
Posts: 39
Joined: Mon Nov 23, 2020 6:01 pm

Re: Installation Win10 64bit

Post by mobarainer »

Hi Teddy,

hier die Bilder.
Win10Start_2.png
Win10 Zentrale anlegen Fehler.png
Das bleibt so stehen bis es mit "X" beendet wird.

Der Abruch des Servers mit "Q+Enter" funktionirt.

Rainer
User avatar
teddy
Site Admin
Posts: 264
Joined: Thu May 07, 2020 2:39 pm
Contact:

Re: Installation Win10 64bit

Post by teddy »

Hallo Rainer

Da scheint etwas schief oder gar nicht zu laufen. Unter Linux hast du das nicht?

Gruss
Teddy
mobarainer
Posts: 39
Joined: Mon Nov 23, 2020 6:01 pm

Re: Installation Win10 64bit

Post by mobarainer »

Hallo Teddy,
NEIN.
Linux soweit OK.
Rainer
User avatar
teddy
Site Admin
Posts: 264
Joined: Thu May 07, 2020 2:39 pm
Contact:

Re: Installation Win10 64bit

Post by teddy »

Hallo Rainer

Dann werde ich mir das unter Windows mal ansehen.

Gruss
Teddy
mobarainer
Posts: 39
Joined: Mon Nov 23, 2020 6:01 pm

Re: Installation Win10 64bit

Post by mobarainer »

Hi Teddy,
Habe nach einem Windows-Update den PC neu gestartet. Nun geht es wieder mit der Konfiguration der Zentralen.
Rainer
User avatar
teddy
Site Admin
Posts: 264
Joined: Thu May 07, 2020 2:39 pm
Contact:

Re: Installation Win10 64bit

Post by teddy »

Danke für die Info Rainer!

Dann muss ich da ja keine Geister suchen.

Gruss
Teddy
Post Reply